package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<link href=\"css\/[a-zA-Z\-]+\.css\"[a-zA-Z=\"\/ ]+>`)
var str = `<link href="css/normalize.css" >
<link href="css/normalize.css" rel="stylesheet" type="text/css">
<link href="css/components.css" rel="stylesheet" type="text/css">
<link href="css/style-sheet.css" rel="stylesheet" type="text/css">
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}