// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<link href=\"css\/[a-zA-Z\-]+\.css\"[a-zA-Z=\"\/ ]+>"#).unwrap();
let string = "<link href=\"css/normalize.css\" >
<link href=\"css/normalize.css\" rel=\"stylesheet\" type=\"text/css\">
<link href=\"css/components.css\" rel=\"stylesheet\" type=\"text/css\">
<link href=\"css/style-sheet.css\" rel=\"stylesheet\" type=\"text/css\">
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}