use strict;
my $str = '111222333444
11222333444';
my $regex = qr/\d{3}(?!$)\K/mp;
my $subst = '.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";