using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[1-4](?:\.\d+)?|5(?:\.0+)?)$";
string input = @"Do match (Expectation):
1
1.5
1.584
2
4.68756
5
Don't match (Expectation):
0
.5
0.99
01
05
5.1
6";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}