package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[1-4](?:\.\d+)?|5(?:\.0+)?)$`)
var str = `Do match (Expectation):
1
1.5
1.584
2
4.68756
5
Don't match (Expectation):
0
.5
0.99
01
05
5.1
6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}