// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[1-4](?:\.\d+)?|5(?:\.0+)?)$").unwrap();
let string = "Do match (Expectation):
1
1.5
1.584
2
4.68756
5
Don't match (Expectation):
0
.5
0.99
01
05
5.1
6";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}