$re = '/^(90|[0-8][0-9]?)$/m';
$str = '1
43
568
90
89
32
356
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);