import Foundation
let pattern = #"^(\(\d+,\d+,'[\d\w]+',\d+,\d+,\d+,\d+,\d+,\d+,\d+\))(,(\(\d+,\d+,'[\d\w]+',\d+,\d+,\d+,\d+,\d+,\d+,\d+\))|,{,1})*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"(2,3,'men1',56,45,45,45,45,45,5),(2,3,'men1',6,45,45,45,45,45,45)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)