package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(\bcout)(s\b|\b)`)
var str = `Test de remplacement de cout.
Egalement gout, tache, cout, maitrise. Par contre on ne remplace pas coût ni tâche.
Test également au pluriel de couts et de goût. `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}