$re = '/^(?=.{5}$)a*b*$/m';
$str = 'aaabb
aabbb
aaaaa
aaabbb
ab
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);