using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"users\/(.*?)\&";
string input = @"https://www.myapi.com/player/?url=https%3A//myapi.com/users/11468859&color=788b78&auto_play=false&show_artwork=false";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}