using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\A|;)(?:\s*)((?:%macro |%inc(?:lude)?\b|data |proc )[^;]+)";
string substitution = @"";
string input = @"%macro foo;
%inc ""foo.sas"";
%mend;
%macro mylogit1(all_deps, outest);
%let k=1;
%let dep = %scan(&all_deps, &k);
%do %while(""&dep"" NE "");
title ""dependent variable is &dep"";
proc logistic data=xxx des outest=_est&k;
model &dep = ind1 ind2;
run;
%let k = %eval(&k + 1);
%let dep = %scan(&all_deps, &k);
%end;
%if ""&outest"" NE "" %then
%do;
data &outest;
set
%do i = 1 %to &k - 1;
_est&i
%end;
;
run;
%let k = %eval(&k - 1);
proc datasets;
delete _est1 - _est&k;
run;
%end;
%else
%do;
%put no dataset name was provided, files are not combined;
%end;
%mend;
%mylogit1(v1 v2 v3);
%mylogit1(v1 v2 v3, a);
proc print data = a;
var intercept ind1 ind2;
run;
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}