Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?:\A|;)(?:\s*)((?:%macro |%inc(?:lude)?\b|data |proc )[^;]+)
/
g
Input 1
1
New
%macro foo; %inc "foo.sas"; %mend; %macro mylogit1(all_deps, outest); %let k=1; %let dep = %scan(&all_deps, &k); %do %while("&dep" NE ""); title "dependent variable is &dep"; proc logistic data=xxx des outest=_est&k; model &dep = ind1 ind2; run; %let k = %eval(&k + 1); %let dep = %scan(&all_deps, &k); %end; %if "&outest" NE "" %then %do; data &outest; set %do i = 1 %to &k - 1; _est&i %end; ; run; %let k = %eval(&k - 1); proc datasets; delete _est1 - _est&k; run; %end; %else %do; %put no dataset name was provided, files are not combined; %end; %mend; %mylogit1(v1 v2 v3); %mylogit1(v1 v2 v3, a); proc print data = a; var intercept ind1 ind2; run;
Substitution
%macro foo; %inc "foo.sas"; %mend; %macro mylogit1(all_deps, outest); %let k=1; %let dep = %scan(&all_deps, &k); %do %while("&dep" NE ""); title "dependent variable is &dep"; proc logistic data=xxx des outest=_est&k; model &dep = ind1 ind2; run; %let k = %eval(&k + 1); %let dep = %scan(&all_deps, &k); %end; %if "&outest" NE "" %then %do; data &outest; set %do i = 1 %to &k - 1; _est&i %end; ; run; %let k = %eval(&k - 1); proc datasets; delete _est1 - _est&k; run; %end; %else %do; %put no dataset name was provided, files are not combined; %end; %mend; %mylogit1(v1 v2 v3); %mylogit1(v1 v2 v3, a); proc print data = a; var intercept ind1 ind2; run;