const regex = /(([A-z.]{3,9}|[0-9]{1,2}) [0-9]{1,2}[, ]{1,2}[0-9]{1,4})|(([A-z.]{3,9}|[0-9]{1,2})[ ,][0-9]{1,4})|([0-9]{1,4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([A-z.]{3,9}|[0-9]{1,2}) [0-9]{1,2}[, ]{1,2}[0-9]{1,4})|(([A-z.]{3,9}|[0-9]{1,2})[ ,][0-9]{1,4})|([0-9]{1,4})', 'g')
const str = `May 5, 2010
2010
Mar. 1990
5 1990`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}