package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^(.*):)`)
var str = `14:15
14:2
10:2
1:20
1:5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}