$re = '/^(?!-|.*-$|.*-[\W_]|.*[\W_]-).*$/mi';
$str = 'sdh-sdj-dsjh-dh
sjkksd--
-sdgdsj--djbjsd
-sdgdsj-djbjsd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);