re = /^(?!-|.*-$|.*-[\W_]|.*[\W_]-).*$/mi
str = 'sdh-sdj-dsjh-dh
sjkksd--
-sdgdsj--djbjsd
-sdgdsj-djbjsd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end