#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?:\G(?!^)|[\w-]{2}(?=[\w-]*@))\K[^@]"
Local $sString = "example@gmail.com"
Local $sSubst = "*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)