using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?=.*[a-z])(?=.*[A-Z])(?=.*[\d])(?=.*[@#%$£&*])\S{8,50})$";
string input = @"Testtest@3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}