package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w*$`)
var str = `ventas@mobilis.com.mx;242101M205;600;CLP-02-SEN-HARN;3013050;B207;00020068785;H7616I03`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}