// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\w*$").unwrap();
let string = "ventas@mobilis.com.mx;242101M205;600;CLP-02-SEN-HARN;3013050;B207;00020068785;H7616I03";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}