#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((([A-Za-z]{3,9}:(?:\/\/)?)(?!(www\.|support\.)*apple\.com|(www\.|forums\.|images\.|cdn\.)*macrumors\.com|(www\.)*youtube\.com|(www\.)*amazon\.|amzn\.to|a\.to)[A-Za-z0-9.-]+[A-Za-z0-9.-]+)((?:\/[\+~%\/.\w-_]*)?\??(?:[-\+=&;%@.\w_]*)#?(?:[\w]*))?)"
Local $sString = "link: [URL] https://www.itunes.com [/URL]" & @CRLF & _
"" & @CRLF & _
"cds http://www.apple.com" & @CRLF & _
"" & @CRLF & _
"cds https://wkmclds.com " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://itunes.com" & @CRLF & _
" htt" & @CRLF & _
"dcklscmdskl https://cdn.macrumors.com" & @CRLF & _
"http://up.co" & @CRLF & _
"http://amazo" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"spam spam"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")