# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((([A-Za-z]{3,9}:(?:\/\/)?)(?!(www\.|support\.)*apple\.com|(www\.|forums\.|images\.|cdn\.)*macrumors\.com|(www\.)*youtube\.com|(www\.)*amazon\.|amzn\.to|a\.to)[A-Za-z0-9.-]+[A-Za-z0-9.-]+)((?:\/[\+~%\/.\w-_]*)?\??(?:[-\+=&;%@.\w_]*)#?(?:[\w]*))?)"
test_str = ("link: [URL] https://www.itunes.com [/URL]\n\n"
"cds http://www.apple.com\n\n"
"cds https://wkmclds.com \n\n\n"
"https://itunes.com\n"
" htt\n"
"dcklscmdskl https://cdn.macrumors.com\n"
"http://up.co\n"
"http://amazo\n\n\n"
"spam spam")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.