using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.{1025})/?[^/\n]*[^/.\n](?:/[^\n/]*[^/.\n]){0,253}$";
string input = @"/a
/a.txt
/a/b
/a/b.txt
a
a.txt
a/b
a/b.txt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}