use strict;
my $str = 'Matches
-------
1
9
10
100
999
1000
9999
10000
20000
24999
25000
Doesn\'t match
-------------
0
01
00009
25001
99999
';
my $regex = qr/^([1-9]\d{0,3}|1\d{4}|2[0-4]\d{3}|25000)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}