#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(2[0-3]|1?[0-9])?(\.[0-5]?[0-9])?$"
Local $sString = "0" & @CRLF & _
"1" & @CRLF & _
".58" & @CRLF & _
".59" & @CRLF & _
".60" & @CRLF & _
".123" & @CRLF & _
"23.1" & @CRLF & _
"23.59" & @CRLF & _
"24" & @CRLF & _
"24.0" & @CRLF & _
"24.01" & @CRLF & _
"123" & @CRLF & _
"123." & @CRLF & _
"."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")