package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(2[0-3]|1?[0-9])?(\.[0-5]?[0-9])?$`)
var str = `0
1
.58
.59
.60
.123
23.1
23.59
24
24.0
24.01
123
123.
.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}