// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(2[0-3]|1?[0-9])?(\.[0-5]?[0-9])?$").unwrap();
let string = "0
1
.58
.59
.60
.123
23.1
23.59
24
24.0
24.01
123
123.
.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}