package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{4}\-(0?[1-9]|1[012])\-(0?[1-9]|[12][0-9]|3[01])*`)
var str = `Bla bla bla 2017-12-12 bla bla bla lkasjdfklsad 2011-12-3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}