import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\w+(?=\\.))";
final String string = "all_scores.feather\n"
+ "scores_01_clean.feather\n"
+ "scores_02_clean.xlsx\n"
+ "analysis_descriptive.nb.html\n"
+ "analysis_table_01.docx\n"
+ "python_model.py";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}