#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*Tag4).*\/Group1\/.*"
Local $sString = "/Group1/Tag1" & @CRLF & _
"/Group1/Tag2" & @CRLF & _
"/Group1/Tag3" & @CRLF & _
"/Group1/GroupVoltage/Tag1" & @CRLF & _
"/Group1/GroupVoltage/Tag2" & @CRLF & _
"/Group1/GroupVoltage/Tag3" & @CRLF & _
"/Group1/GroupVoltage/Tag4" & @CRLF & _
"/Group2/Tag1" & @CRLF & _
"/Group2/Tag2" & @CRLF & _
"/Group2/Tag3" & @CRLF & _
"/Group2/GroupVoltage/Tag1" & @CRLF & _
"/Group2/GroupVoltage/Tag2" & @CRLF & _
"/Group2/GroupVoltage/Tag3" & @CRLF & _
"/Group2/GroupVoltage/Tag4" & @CRLF & _
"/Group3/Tag1" & @CRLF & _
"/Group3/Tag2" & @CRLF & _
"/Group3/Tag3" & @CRLF & _
"/Group3/GroupVoltage/Tag1" & @CRLF & _
"/Group3/GroupVoltage/Tag2" & @CRLF & _
"/Group3/GroupVoltage/Tag3" & @CRLF & _
"/Group3/GroupVoltage/Tag4" & @CRLF & _
"/Group4/Tag1" & @CRLF & _
"/Group4/Tag2" & @CRLF & _
"/Group4/Tag3" & @CRLF & _
"/Group4/GroupVoltage/Tag1" & @CRLF & _
"/Group4/GroupVoltage/Tag2" & @CRLF & _
"/Group4/GroupVoltage/Tag3" & @CRLF & _
"/Group4/GroupVoltage/Tag4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")