import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*Tag4).*\\/Group1\\/.*";
final String string = "/Group1/Tag1\n"
+ "/Group1/Tag2\n"
+ "/Group1/Tag3\n"
+ "/Group1/GroupVoltage/Tag1\n"
+ "/Group1/GroupVoltage/Tag2\n"
+ "/Group1/GroupVoltage/Tag3\n"
+ "/Group1/GroupVoltage/Tag4\n"
+ "/Group2/Tag1\n"
+ "/Group2/Tag2\n"
+ "/Group2/Tag3\n"
+ "/Group2/GroupVoltage/Tag1\n"
+ "/Group2/GroupVoltage/Tag2\n"
+ "/Group2/GroupVoltage/Tag3\n"
+ "/Group2/GroupVoltage/Tag4\n"
+ "/Group3/Tag1\n"
+ "/Group3/Tag2\n"
+ "/Group3/Tag3\n"
+ "/Group3/GroupVoltage/Tag1\n"
+ "/Group3/GroupVoltage/Tag2\n"
+ "/Group3/GroupVoltage/Tag3\n"
+ "/Group3/GroupVoltage/Tag4\n"
+ "/Group4/Tag1\n"
+ "/Group4/Tag2\n"
+ "/Group4/Tag3\n"
+ "/Group4/GroupVoltage/Tag1\n"
+ "/Group4/GroupVoltage/Tag2\n"
+ "/Group4/GroupVoltage/Tag3\n"
+ "/Group4/GroupVoltage/Tag4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}