use strict;
my $str = '/Group1/Tag1
/Group1/Tag2
/Group1/Tag3
/Group1/GroupVoltage/Tag1
/Group1/GroupVoltage/Tag2
/Group1/GroupVoltage/Tag3
/Group1/GroupVoltage/Tag4
/Group2/Tag1
/Group2/Tag2
/Group2/Tag3
/Group2/GroupVoltage/Tag1
/Group2/GroupVoltage/Tag2
/Group2/GroupVoltage/Tag3
/Group2/GroupVoltage/Tag4
/Group3/Tag1
/Group3/Tag2
/Group3/Tag3
/Group3/GroupVoltage/Tag1
/Group3/GroupVoltage/Tag2
/Group3/GroupVoltage/Tag3
/Group3/GroupVoltage/Tag4
/Group4/Tag1
/Group4/Tag2
/Group4/Tag3
/Group4/GroupVoltage/Tag1
/Group4/GroupVoltage/Tag2
/Group4/GroupVoltage/Tag3
/Group4/GroupVoltage/Tag4';
my $regex = qr/^(?!.*Tag4).*\/Group1\/.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}