package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<base>.+?)\s*(?:\((?<idx>\d+)\))?(?<ext>\.[\w.]+)?$`)
var str = `somefile.docx
somefile
somefile (6)
somefile (1).docx
somefile (2)(1).docx
somefile (4).htm.tmpl`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}