package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\"([^"]+?)\"`)
var str = `She said "hello," and he replied "fine."`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}