re = /(\/)(?=\*)(?:\*)((?:\1|[\s\S])*?)(?:\*)\1|(?=\/\/(.*))|(\<![\-\-\s\w\>\/]*\>)/m
str = '/*
something
*/
/* something */
/*
* // something
*
*/
/*/something/*/
// teste
<!-- HTML Comment //-->
or
<!-- HTML Comment -->'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end