package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*(example).*)`)
var str = `This is an example message`
var substitution = "~r~6Message found containing $2:\n~r~e$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}