using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\W|_";
string input = @"foo__123!""§$bar BAZ foo__123!""§$bar BAZ foo__123!""§$bar BAZ foo__123!""§$bar BAZ foo__123!""§$bar BAZ foo__123!""§$bar BAZ foo__123!""§$bar BAZ foo__123!""§$bar BAZ foo__123!""§$bar BAZ foo__123!""§$bar BAZ foo__123!""§$bar BAZ foo__123!""§$bar BAZ foo__123!""§$bar BAZ foo__123!""§$bar BAZ foo__123!""§$bar BAZ foo__123!""§$bar BAZ foo__123!""§$bar BAZ foo__123!""§$bar BAZ
";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}