package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-(?<my_field>.*)\s+-`)
var str = `Access - My string - July - Splunk`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}