package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)#([\w.]+)`)
var str = `#quote#öquoteoftheday #şmyquote`
var substitution = "<a href="/tag/$1">#$1</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}