const regex = /#([\w.]+)/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#([\\w.]+)', 'gmu')
const str = `#quote#öquoteoftheday #şmyquote`;
const subst = `<a href="/tag/$1">#$1</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);