$re = '/#([\w.]+)/mu';
$str = '#quote#öquoteoftheday #şmyquote';
$subst = "<a href=\"/tag/$1\">#$1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;