#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[0-3]?\d([\,\-\/ ])(?<Bulan>(?<Januari>[Jj]an|[Jj]anuari)|(?<Februari>[Ff]ebruari|[Ff]eb)|(?<Maret>[Mm]aret|[Mm]ar)|(?<April>[Aa]pril|[Aa]pr)|(?<Mei>[Mm]ei|[Mm]ay)|(?<Juni>[Jj]uni|[Jj]une)|(?<Juli>[Jj]uli|[Jj]uly)|(?<Agustus>[Aa]gustus|[Aa]ug)|(?<September>[Ss]eptember|[Ss]ept)|(?<Oktober>[Oo]ktober|[Oo]ct)|(?<November>[Nn]ovember|[Nn]ov)|(?<Desember>[Dd]esember|[Dd]ec))\1([12]\d{3}|\d{2})"
Local $sString = "12-Maret-2021"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")