#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?<=[\d ])[()-]+ *"
Local $sString = "firstname lastname (123) 456-7890" & @CRLF & _
"firstname lastname (234) 567-8910" & @CRLF & _
"firstname last-name 345-678-9101"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)