$re = '/(?<=[\d ])[()-]+ */i';
$str = 'firstname lastname (123) 456-7890
firstname lastname (234) 567-8910
firstname last-name 345-678-9101';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;