import Foundation
let pattern = #"((^)|(.))adchoice."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ####"""
### this is probably what you want to block
adchoice.com
aadchoice.com
0adchoice.com
2adchoice.com
anystring-adchoice.com
www.adchoice.com
### this is probably not what you want
badchoices
www.mybadchoice.com
madchoices.com
www.badchoice.in # (real domain)
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)