$re = '/\w+[\]|\w+[\,]\w+|\.|\?/';
$str = '"mary went to garden. where is mary? mary is carrying apple and milk. what mary is carrying? apple,milk" ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);