import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Z][A-HJ-Y]?[0-9][A-Z0-9]? ?[0-9][A-Z]{2}|GIR ?0A{2})$";
final String string = "A1A 1AA\n"
+ "A1 1AA\n"
+ "A11 1AA\n"
+ "AA1 1AA\n"
+ "AA1A 1AA\n"
+ "AA11 1AA\n"
+ "A1A1AA\n"
+ "A11AA\n"
+ "A111AA\n"
+ "AA11AA\n"
+ "AA1A1AA\n"
+ "AA111AA\n"
+ "GIR 0AA\n"
+ "GIR0AA\n"
+ "a1a 1aa\n"
+ "a1 1aa\n"
+ "a11 1aa\n"
+ "aa1 1aa\n"
+ "aa1a 1aa\n"
+ "aa11 1aa\n"
+ "a1a1aa\n"
+ "a11aa\n"
+ "a111aa\n"
+ "aa11aa\n"
+ "aa1a1aa\n"
+ "aa111aa\n"
+ "gir 0aa\n"
+ "gir0aa";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}