const regex = /^(?!(?:10ofthose\.com|180post\.net)$)[0-9]{2}[a-z]+\.(?:net|com)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(?:10ofthose\\.com|180post\\.net)$)[0-9]{2}[a-z]+\\.(?:net|com)$', 'gm')
const str = `99abc.com
78c.net
10ofthose.com
180post.net`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}