use strict;
my $str = '+@lin+\'select 1,\'\'hello\'\'\'
+@lin+\'from-- two tabs exist after from\'
+@lin+
+@lin+ \'table1\'';
my $regex = qr/(\G(?!^)|^\+@lin\+)\t/mp;
my $subst = '$1@tab+';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";